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Introduction:

MailSteward Pro™
Safely archive thousands of emails

Access your email with all the power of a relational database

Have you ever wished you could find all those emails between you and your client, Joe, during 
August and September of last year, that mention the word 'contract'? Now you can. And you can 
sort them, print them, save them, and export them in several standard formats. MailSteward Pro 
elegantly solves your email archiving, accessing, and management problems. 

Email clients, like the Apple OS X Mail application and Gmail, are very good at sending and 
receiving email, and doing simple searches, but they are not really designed to efficiently and 
safely archive and do sophisticated searches on tens of thousands of emails.Email has become a 
vital part of many professional and personal lives. For many, it is not unusual to send and receive 
thousands of emails every month. Businesses and individuals with large amounts of important 
email need to be able to:

• safely archive email text and attachments so that none of it is ever lost.

• easily and effectively find particular emails, by any combination of sender, recipient, date 
range, keywords, and tags.

• export email in standard formats to prevent data obsolescence.
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The first time you launch MailSteward Pro, after connecting to the MySQL server, this is what 
you will see:

By default MailSteward Pro will automatically select all of your Apple OS X Mail application 
email accounts to be archived, and create an empty MySQL database named "myemaildb". All 
you have to do is click on Archive button, and MailSteward Pro will begin copying your email 
into the database.

Or if you use Gmail instead of Apple Mail, you can periodically download your email from your 
online Gmail account and import it into your MailSteward Pro database and thereby have not 
only the peace of mind of having a local backup of all of your Gmail but also access to all of 
MailSteward's sophisticated search, tagging and other capabilities.

Any of the default settings can be changed by clicking on the Settings button.

You don't have to worry about doing anything to your email files. They are left untouched. 

You don't have to worry about duplicates. If an email is already in the database and you archive it 
again, MailSteward Pro will skip it rather than add a new entry.

Once they have all been copied into the database, you can delete all or most of the email from 
your In and Sent boxes, if you wish. MailSteward Pro will archive the attachments, HTML, 
enriched text, and the original raw source of your email, as well as the plain text. 

Then, whenever you need to find an email, you can use MailSteward Pro.
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Once your email is in a database, it can be retrieved by clicking on the search button and 
specifying any combination of:

• A range of beginning and ending dates.
• keywords or phrases in the From address.
• keywords or phrases in the To address.
• keywords or phrases in the Subject line.
• keywords or phrases in the Body text.
• text strings in the Mailbox name.
• text strings in an attachment file name.
• Text inside attachments that contain text.
• Tags - category, keywords, notes, and/or priority.

Or, if you know SQL, by editing the generated SQL statement.

And you can sort the retrieved emails by:

• Date
• From
• To
• Subject
• Mailbox
• Or by the unique ID that is assigned to each email
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Features:

• Works seamlessly with the Mac OS X Mail application to archive all your email in a 
relational database.

• Will import most mbox format files exported from Gmail and other email clients such as 
Microsoft Entourage X and Outlook.

• Works with all locally stored POP and IMAP email accounts.
• Select emails from archive by date range and keywords in the To, From, Subject, 

Mailbox, or Body fields.
• Sort by date, To, From, Subject, or unique ID.
• Print email list, or individual email, or all emails in a list.
• Save email list, or individual email, or all emails to a text file.
• Save all attachments of selected emails to separate files.
• Reply to or forward individual emails.
• Add your own tags to email.
• Search attachments, such as word processing documents, that contain any text.
• Schedule MailSteward Pro to archive your email automatically.
• Export emails to a tab-delimited text file, an mbox file, or an SQL file.
• All Mail email and folders are left undisturbed.
• Options to store all attachments, attachments less than a given size, or no attachments.
• Keeps a copy of the raw source of the email.
• Native Cocoa application that supports OS X 10.15 or greater (Catalina, Big Sur, 

Monterey, Ventura, Sequoia, Tahoe).
• The free version of MailSteward Pro has full functionality, but is limited to a capacity of 

15,000 emails.
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Installing MySQL on your local computer:

To install MySQL database server software on a Mac running OS X 10.15 or higher (Catalina, 
Big Sur, Monterey, Ventura, Sequoia, Tahoe), click on this download link. Then choose to 
download either the macOS 15 (ARM, 64-bit), DMG Archive or the macOS 15 (x86, 64-bit), 
DMG Archive. This will download a dmg containing a package file. Open the .dmg file and 
double click on the .pkg file to install the MySQL server and to also install the MySQL system 
preference pane, which you can use to start and stop the MySQL server.

During the installation process, if given the option, make sure you choose <strong>Use Legacy 
Password Encryption</strong>. Do NOT choose <strong>Use Strong Password Encryption</
strong>.

The password you set for the MySQL server software is for the default user named 'root'. Note 
that this has nothing to do with your computer's 'root' user.  It is entirely separate. This is not 
your system root user. It is just the MySQL server root user.
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Upgrading to MailSteward Pro from MailSteward: 

If you are upgrading to MailSteward Pro from MailSteward, you can move all of your archived 
email over to the Pro version by following these steps: 

1. In MailSteward, do a Browse to list all of the email in your database. 

2. Choose SQL file... from the Export drop-down. 

3. Choose a name for the MySQL database that will either be created or added to, and enter a 
beginning ID number if different than the default of 1. If you are adding email to an existing 
database, you will need to make sure that the beginning ID is greater than the highest ID number 
in the existing database. 

4. In MailSteward Pro, choose Import MailSteward SQL File... from the File menu, and select 
the SQL file that you just exported from MailSteward. 

All of the email that you exported from MailSteward will now be in the MySQL database with 
the name you chose for the database when exporting the SQL file. Enter this database name in 
the text box in the MailSteward Pro General Settings, and click on Save Settings. 

There is an excellent open source Mac Cocoa MySQL management program called Sequel Ace, 
which can be obtained here. You can use this software to view and edit, export and import any 
MySQL database, including a MailSteward Pro MySQL database.
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Connect to MySQL© Server: 

When MailSteward Pro is launched, before archiving, searching, or browsing can be done, a 
connection to a MySQL server must be established. 

To connect to a server, fill in the host, by default 'localhost', user, by default 'root', and password, 
if you have assigned a password, and click on the Connect button. You can also specify a socket 
and port if necessary. If no socket is entered, the default is assumed to be at /tmp/mysql.sock. If 
you are running the Mac OS X Server system, which has MySQL already installed, the standard 
location for the socket will be /var/mysql/mysql.sock. 

Normally you will connect as the MySQL 'root' user, but if you have created other MySQL users, 
you can use them instead.  If you have not assigned a password to the root user, leave the 
password box blank.
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Specifying a particular database is optional. You can do that later in the Settings window. If no 
database is specified, the database which is set in Settings will be used.  If MailSteward Pro is 
being launched for the first time, and no database is specified, a default database named 
'myemaildb' will be created.  A connection name can be given to the connection and the 
connection information can be saved by clicking on the Save button. Saved connections can be 
deleted by clicking on the Delete button. Once you have created a saved connection, it will 
automatically be filled in whenever you launch MailSteward Pro.
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Connect to MySql on an AWS RDS MySQL database Insance:

Once the database instance is set up and available, something called the "endpoint" will be 
displayed. Here is an example of what the endpoint will look like: 

myemaildb-cluster.cluster-cenpsqh3jxdq.us-east-1.rds.amazonaws.com

This will be what you use as the host when connecting MailSteward Pro to the database instance. 
The port you will use is 3306. The user and password and database name will be whatever you 
specified when creating the database instance. Your MailSteward Pro Connect to Server window 
will look something like this:
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Connect to MySql on an OS X Server Machine:

If you are running the MySQL server on an OS X Server machine, and wish to connect to it from 
anywhere on your local area network, you will need to grant privileges to everyone on the LAN. 
You can do this with the 'mysql' utility. First type the following on the command line in a 
terminal window:

mysql -u root -p

Enter your password when prompted and then enter the following (all on one line): 

mysql> GRANT ALL PRIVILEGES ON *.* TO 'root'@'10.0.1.%'
IDENTIFIED BY "password" WITH GRANT OPTION

You will need to substitute the appropriate IP address and password. The "%" is a wildcard 
which is used to allow connection from any host on the LAN. Your local IP addresses may be 
different. For example they might all begin with "192.168.0." rather than "10.0.1.". 

Your connection to the MySQL server will then look something like this: 

You will find the hostname of your OS X Server by clicking on Sharing in System Preferences 
on the server. 
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Meeting Federal Legal Requirements: 
On April 12, 2006 the United States Supreme Court laid down new rules that require companies, 
government agencies, and public school districts to have systems for retrieving email and other 
electronic data that might be needed for evidence in a court case. The new rules were updated 
later that year in December. What this means is that, if you are in charge of a school district's, or 
company's information technology, you are legally required to set up and maintain a system for 
archiving email, and for enabling quick and easy access to it. 

There are a few products and services available for accomplishing this responsibility. According 
to an excellent article in Education Week's Digital Directions magazine, a school district in New 
Jersey spent about $50,000 on a system for archiving their email.

For smaller school districts and companies the available solutions are likely to be too expensive 
and complicated for them to implement. MailSteward Pro is a Macintosh-based solution that is 
easy to set up and maintain, providing automatic archiving and sophisticated searching of large 
volumes of email. 

For organizations that are running their own mail server, MailSteward Pro can be set up to 
automatically archive all incoming and outgoing email. If the mail server is configured to put 
copies of all email coming in or going out, into a particular directory, MailSteward Pro can then 
be configured in the Settings to always import any email that exists in that directory. Simply 
check the box that says "Import email from this folder", and then click on "Choose..." to enter the 
path to the directory containing the copies of the email. If there are subdirectories, MailSteward 
Pro will also archive any email that they contain. 

For organizations that are not running their own mail server, each individual in the organization 
can have a copy of MailSteward Pro that is set up to automatically, on a schedule, archive their 
email into a central MySQL database on a network server.
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Settings: 

Clicking on Settings brings up the Settings window. When you first launch MailSteward Pro the 
default Settings are in place. MailSteward Pro will create a MySQL database'myemaildb'. If you 
click on Archive, MailSteward Pro will archive the email in all of the email accounts that you 
have in the OS X Mail application. There are also default settings for a number of other options. 
Settings are assocated with a database. Each database, if you have more than one, has its own 
settings. There are several different panels in the Settings window, which are described below. 
When any of the Settings have been changed, click on the Save Settings button to save the 
changes. You can also reset all of the Settings back to the defaults by clicking on the Reset 
button.

The General Settings panel is where you can choose between the Apple Mail email client or no 
email client, and where you can open an existing database, or create a new one, by choosing a 
database from the drop-down menu, or by entering the name of a new database into the text box 
and saving the settings.  The name of the current database is shown in the text box.  There is an 
option to limit the size of archived attachments to some number of megabytes.  There are also 
options to specify whether or not to include Trash and Junk mailboxes. Duplicate emails that are 
already in the database are skipped when archiving. If you don't wish to skip duplicates, you can 

TM & Copyright © 2004-2026 pubblog.com. All rights reserved.

http://www.pubblog.com/


MailSteward Pro Manual Page 14

check the box that says, "Do not skip duplicates when archiving". You can also choose to set an 
upper limit on the number of emails retrieved by searching or browsing, and you can choose to 
always launch attachments when they are clicked on instead of being asked whether to launch 
them or save them as files. By default, MailSteward Pro will automatically check for new 
versions. By default MailSteward will use the light/dark appearance defined in the System 
Preferences, but you can optionally choose an appearance that will be used regardless of the 
system setting.

This panel allows you to select the email accounts or mailboxes that you wish to archive.  By 
default all email accounts are selected.  You can choose whether to select accounts or select 
mailboxes.  You select an account or mailbox by clicking on the checkbox next to it. You may 
have to select mailboxes instead of accounts in the MailSteward settings to make sure you are 
archiving email that may have been moved into mailboxes other than In and Sent. This is 
especially true of some gmail accounts, which are handled differently by Apple Mail.

You can also tell MailSteward Pro to always archive any email mbox files that are in a particular 
folder.  MailSteward Pro will then look for email files in the specified folder and all of its 
subfolders and archive them in addition to the email in the selected accounts or mailboxes.  If the 
box is checked to "Delete email in this folder after it is archived", then the email files in the 
designated import folder will be deleted once they have been archived. This only applies to email 
in this special folder. MailSteward Pro never deletes email from the Apple Mail application.
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The Viewing panel lets you set the font and the date format to be used when displaying email 
text. Any combination of year, month, day order and separator character (-, /, .) can be chosen for 
the date format.  You can also choose the default sorting order for Browse and Search results.  
Choose any of the fields to sort by, and whether the sort should be ascending or descending.
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If the Save Debug Log menu item in the File menu is checked, a log file will be saved on your 
Desktop with the same name as your database and an extension of .log. It will contain a list of 
the email files that have been processed. If MailSteward Pro should crash or be interrupted for 
any reason, the last file in the list will be the file that MailSteward Pro was processing at the time 
it was terminated.
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If you have multiple databases with different settings, you can save a copy of your settings and 
later use it to replace the current settings, allowing you to switch between databases easily. 
Choose Save Copy of Settings... from the File menu to save a copy of the current settings. 
Choose Replace Settings with Saved Copy... to replace the current settings with a saved copy. 
Once the settings have been replaced, MailSteward Pro will quit and you will need to relaunch it 
for the replaced settings to take effect. Make sure to enter the correct database name in the 
Connect window when MailSteward Pro relaunches.

The Scheduling Settings are explained in a separate section of this manual, Schedule Archive.
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Archive Email: 
Clicking on the Archive button will bring up this window:

MailSteward Pro will automatically set the beginning date to the date of the most recent email 
archived in the database. Any email prior to that date will be skipped. This will save time if you 
have already processed email prior to a given date. Or you can set the date to "All" for month, 
day, and year, and MailSteward Pro will process all of the email in your account(s).  You can also 
set an ending date. This can be useful if you want to, for example, just store all of the email prior 
to 2004. Clicking on the Reset All button will reset the beginning and ending dates to "All".

Once you have chosen a beginning date and/or ending date, and clicked on the Archive button, 
MailSteward Pro will begin processing your locally stored email and archiving it into the 
database. If you have a .mac or other imap account, you must set the account options to keep 
copies of your email on your local computer. MailSteward Pro does not access email on remote 
servers. Duplicate email is automatically skipped.  If an email is already in the database, it is not 
archived.  However, if the mailbox has changed, or the email tags have changed, they will be 
updated in the database. 
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While the email is being archived, this sheet provides continuous feedback:

Clicking on the Stop button will stop the archiving operation and save all of the email in the 
database that has been processed so far.If in the middle of processing an email or attachment, it 
may take a little time for the Stop button to take effect.

When all of the email has been archived in the database, a window will appear showing 
MailSteward Pro is done archiving. Information will also be logged in an archive history file. 
You can view the archive history by choosing "Archive History" from the File menu.

Depending on the options chosen in the Settings window, MailSteward Pro will store the text, the 
HTML and enriched text versions, the raw source, and, optionally, the attachments. Once 
MailSteward Pro is done archiving the email, you can:

• Launch or save the attachments of individual emails.
• Add tags to email.
• Reply to an email.
• Forward an email.
• Print the email list.
• Print the individual selected email
• Print all the email in the list.
• Save the email list.
• Save the individual selected email.
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• Save all the email in the list.
• Save the raw source of the selected email.
• Save the raw source of all the email in the list.
• Save all attachments of selected emails to separate files.
• Delete the selected email from the list.
• Delete the selected email from the database & the list.
• Delete all of the email in the list, from the database.
• Delete attachments of the selected email in the list, from the database.
• View the raw source of the selected email.
• Export email to a tab-delimited text file, an mbox file, or an SQL file.

If an email has attachments or an HTML or enriched text version that has been saved in the 
database, a list of the attachments will appear at the bottom of the email text as a blue, underlined 
link beneath the title ATTACHMENTS:. Clicking on the link of an attachment will allow you to 
launch the attachment using the appropriate application, or save the attachment as a file. The 
number of attachments for each email appears in the ATCH column. 

You can view the raw source of the selected email by clicking on the View Raw Source item in 
the Window menu. You can also Search for email in the database by any combination of date 
range, key words, and tags.
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Search Email: 
Once your email is in the database, it can be retrieved by specifying any combination of:

• A range of beginning and ending dates.
• keywords or phrases in the From address.
• keywords or phrases in the To address.
• keywords or phrases in the Subject line.
• keywords or phrases in the Body text.
• text strings in the Mailbox name.
• text strings in an attachment file name.
• text strings in attachment contents, if the attachment contains any text.
• text strings in the raw headings of the email.
• A text string anywhere in the email in any of the fields.
• Tags - category, keywords, priority.
• attachment types, such as graphics, documents, video, etc.

Or, if you know SQL, by editing the SQL statement generated by MailSteward Pro.

If the only email with attachments check box is checked, then only email with attachments will 
be retrieved. If an email has attachments or an HTML or enriched text version that has been 
saved in the database, a list of the attachments will appear at the bottom of the email text as a 
blue, underlined link beneath the title ATTACHMENTS:. Clicking on the link of an attachment 
will allow you to launch the attachment using the default application for the type of file, or save 
the attachment as a file. The number of attachments for each email appears in the ATCH column. 

Binary attachments, like graphics, sound files, Word documents, or PDF files, are stored in their 
original binary format. Any attachments that contain text, such as Word documents, can be 
searched. However, the text in PDF documents is encoded such that it cannot be searched.

Clicking on the drop-down menu next to the mailbox field will display a list of all the unique 
mailboxes in the database. Clicking on one of the mailboxes in the list will place it in the 
mailbox search field. 

Clicking on the Reset button will set all of the search criteria back to the default. 

Once the search is done and the email has been retrieved, you can click on the header of any 
column to sort in ascending or descending order. 

If you click on the Search List button  you can refine your search by doing a search within 
the current search results list. 

If you click on the View raw source button , a separate window will open containing the raw 
source of the selected email with all of the original header information. 

TM & Copyright © 2004-2026 pubblog.com. All rights reserved.

http://www.pubblog.com/


MailSteward Pro Manual Page 22

Click on the Reply icon, to reply to the selected email. The OS X Mail application will be 
launched and an email message window opened, with the From, To, and Subject information 
filled in, and the text of the message being replied to, inserted in the body.

Each of the field label drop-down buttons can be changed to a different field label. So you can 
search for multiple keywords or phrases in the same field. You can also drop down the buttons to 
the left of the field labels to select AND, OR, AND NOT, or OR NOT. 

The above search criteria will generate an SQL statement that will return all of the emails either 
from or to Joe Smith that contain either the word "contract" or "proposal" in the body of the 
email or the word "contract" in any attached documents. Also only emails with attachments will 
be retrieved. 
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If you click on the choose attachment types to search button, a sheet will appear where you can 
choose attachment file types grouped as graphics, documents, sound, video, and/or compressed.
If you have tagged some of your email, you can do a search based on your tags, and you can also 
combine the two and do a search that includes both fields and tags.
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You can also search for tags by clicking on the Search Tags tab. In the Tags search window, 
clicking on the drop-down menu next to the Keywords field will display a list of all the unique 
Keywords in the database. Clicking on one of the keywords in the list will place it in the 
Keywords search field.
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Clicking on the Saved Searches button brings up a window to let you save a set of Search 
criteria, or execute a previously saved Search. 

If you click on Set Browse Button, the currently selected saved search will be made the default 
for the Browse  button. Whenever you click on the Browse button, this search will be executed 
instead of listing all of the email in the database. If you click on Reset Browse Button, the 
default for the Browse button will be reset back to listing all email. 

Clicking on the Edit SQL Statement button will bring up the following window, which allows 
you to add parentheses or NOTs, or enter your own SQL.

Clicking on the Show Database Schema button will display a complete list of the tables and 
field names in the MailSteward Pro database structure. 
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Browse Email: 
Clicking on the Browse button will retrieve all of the email in the database, sorted by date. It can 
then be sorted in any order by clicking on the column headers.By default the settings limit the 
search and browse results to 1,000 emails, in order to speed up the process. However, you can 
choose to not limit the results, or to limit them by some number other than 1,000.

Click on the Reply button to reply to the selected email. The OS X Mail application will be 
launched and an email message window opened, with the From, To, and Subject information 
filled in, and the text of the message being replied to, inserted in the body. Clicking on the Fwd 
button will also launch the Mail app and open a new forwarded message window. 

It is also possible to assign one of the saved Searches to the Browse button. For example, you 
could specify a Search that begins in the current year, save the Search, and then assign that 
Search to the Browse button so that when you browse you only see this year's emails rather than 
all of the email in the database. 
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You can also browse by email size and get a list of email sorted by the size of the individual 
emails, in descending order, largest first.  Finding and sorting email by size is somewhat slow, so 
you may want to set a maximum limit on search results in the MailSteward General Settings.
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Backing Up Gmail:

MailSteward is the ultimate backup solution for your Gmail. If you use Apple Mail and have 
your Gmail accounts set up in Apple Mail, then MailSteward is already archiving your Gmail 
into your MailSteward database. But if you don't use Apple Mail and Gmail is your main or only 
email provider, you can still archive all of your Gmail into a MailSteward database and have not 
only the peace of mind of having a local backup of all of your Gmail but also access to all of 
MailSteward's sophisticated search and tagging and other capabilities. Here is how to download 
and import all of your gmail into a MailSteward database:

* Go to takeout.google.com and log in to your gmail account.

*Deselect All to uncheck all the boxes.

*Scroll down to Mail and check the box.

*Click on Next at the bottom of the page.

*Click on Download.

Unzip the downloaded file. This will create a folder in your download folder named Takeout. 
Inside that folder will be another folder named Mail in which will be two mbox files named 
Inbox.mbox and Sent.mbox.

Choose the Import mbox Files... item from the MailSteward File menu and select those two 
mbox files to be imported into your MailSteward database.

That's all there is to it.
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Schedule Archiving: 
MailSteward Pro can be set to automatically schedule an archive of recent email. If you select 
the Scheduling panel in the MailSteward Pro Settings, you can specify a schedule for 
automatically launching MailSteward to do an archive of new email. MailSteward does not need 
to be already running. In fact it's better if it is not running. The schedule will launch MailSteward 
Pro, connect to a running MySQL server, archive all email starting on the most recent date in the 
database, and then it will quit when it is done.

Archives can be scheduled 
either by days of the week, or 
by months and days of the 
month. They can be scheduled 
for any specific time of day, or 
for every so many hours. After 
setting the scheduling options, 
clicking on the Schedule 
button will put an entry into 
your crontab file, which will 
tell the operating system to 
run MailSteward Pro at the 
specified time and dates. 
MailSteward Pro will then 
automatically archive email 
beginning on the date of the 
most recent email in the 
database file. As always, any 
duplicates will be skipped. 

The scheduling options can be changed at any time. If the box to optionally leave a log file is 
checked, then a small text file with information about the completed archive will be left on the 
Desktop, making it easy to see that the archive was done. If you don't want the log file to appear, 
uncheck this box. You can always look at the archive history by choosing it from the File menu.

Clicking on the Remove Schedule button will delete the existing MailSteward Pro schedule.
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Add, Search, & View Tags: 
Clicking on the Tag button in the upper right corner will bring up the Add/View Tags window.  
If the currently selected email has a tag, there will be an asterisk next to the date-time of that 
email in the DATE TIME column, and the tag for that email will appear in the Add/View Tags 
window. You can then add a tag or edit an existing tag by entering your choices and clicking on 
the Tag button.  If multiple emails are selected, they will all be tagged. You can remove tags, by 
clearing out the text boxes, setting the priority to "None" and clicking on the Tag button.   To see 
how searching with tags works, go to the Search Email section. 

You can also define rules to automatically tag email as it is archived, as explained in the Set 
Rules for Tagging section.
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Set Rules for Tagging or Excluding:

Tags can be added to email in the database at any time, but it is also possible to define rules to 
automatically tag email as it is archived into the database. You can also define a rule to exclude 
email from being archived.  Once a rule is defined, it is listed in the Tag Rules Settings and can 
be enabled or disabled by checking the box next to it.  By clicking on the right hand buttons you 
can add a new rule, edit an existing rule, duplicate an existing rule, and remove an existing rule.
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Clicking on the Add Rule, Edit, or Duplicate buttons will drop down a sheet for defining a rule

A rule may have up to four conditions. If the text box for a condition is left blank, that condition 
is ignored. A rule can require all of the conditions to be met, or any one of them to be met, 
depending on whether "all" or "any" is chosen in the top popup button. Once the conditions have 
been set, you can choose to either tag email or exclude email from being archived, based on the 
rule.  If you choose to tag the email, the tag category, keywords, note, and priority can be 
defined.  Clicking on OK will add the rule to the list. As email is archived into the database, it is 
checked against all active rules and tagged or excluded accordingly.  As tag rules are checked, 
tag keywords are added on separated by spaces. The other tags are replaced by subsequent rules.
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Back Up Your Database: 
A MySQL database is not a single file.  It is a collection of files.  As with any files, it is a good 
idea to maintain a backup of your database.  The MySQL server can be configured to keep its 
data anywhere, but in a standard OS X MySQL installation, the data is located in the /usr/local/
mysql/data/ directory.  If your database is named 'myemaildb', for example, the files for that 
database will be located in /usr/local/mysql/data/myemaildb/.  These directories are not normally 
visible in the OS X Finder.  You have to access them in a terminal window, and you have to be 
the OS X system 'root' user in order to do it.  Here is a link that explains how to enable the OS X 
system root user:  http://support.apple.com/kb/HT1528

Using UNIX commands you can navigate to this location and make a copy of your database 
directory as a backup, but there is an easier way to maintain a backup of your database. Click on 
the Backup Database to SQL File... item in the File menu.  This will export your entire 
database in an SQL format that you can always import back into a MySQL database by selecting 
Import MailSteward SQL File... from the File menu. This will restore your database, replacing 
any data that exists in the database, or, if you have deleted the database, it will create a new 
database with the SQL data. This process uses the mysqldump utility to create the SQL file, and 
uses the mysql utility to import the SQL file. These two utilities are part of the standard MySQL 
installation.

Here is a link to some instructions detailing how to move a MySQL database to a different 
location, such as an external disk drive:  https://pubblog.com/nickstek/2009/05/01/moving-
mysql-databases-to-a-different-location/

Here is a link to a discussion of multiple ways to back up a MySQL database: http://
www.noupe.com/how-tos/10-ways-to-automatically-manually-backup-mysql-database.html
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Export a Tab or Comma Delimited Text File, an Mbox File, an SQL File, or a 
list of email addresses: 
Any list of stored or retrieved email can be exported to a tab or comma delimited text file, or to 
an "mbox" format file that can then be imported into most email clients, or to an SQL file that 
can be imported into a MySQL database. Or a list of all the From, To, or both email addresses 
can be exported. Just click on the Export drop-down button and select the desired export format. 
A tab or comma delimited text file can then be imported into FileMaker or Benton or other 
database and spreadsheet applications.  An mbox file can then be imported back into OS X Mail 
or Microsoft Entourage or other email clients, or MailSteward Pro itself. An SQL file can be 
imported into MySQL. If the tab or comma delimited text file option is chosen, attachments and 
tags are not exported. Only the plain text portion of the email is exported. If the SQL option is 
chosen, then everything will be exported, including any attachments and tags and copies of the 
email raw source. In the case of the mbox format, everything will be exported except for the 
mailbox and tags. The standard mbox email format does not include the concepts of tags or 
mailboxes. 

Binary attachments are stored in the original binary format in MailSteward Pro. The SQL 
generated by MailSteward Pro will also cause the binary attachments to be stored in MySQL as 
binary blobs.
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Import mbox Files: 
The Microsoft Entourage X email client uses a 
proprietary database to store email. However if you 
drag a mailbox from Entourage onto your desktop 
or into a folder, Entourage will export the dragged 
mailbox as a standard format UNIX mbox file that 
MailSteward Pro can understand. Entourage only 
converts the email at the top level of any folder that 
you drag. It doesn't convert any email contained in 
subfolders. Each subfolder has to be dragged 
individually. Most other email clients also can 
export mbox files. Mbox files that have been created 
in this way can be read into your MailSteward Pro 
email archive by selecting Import mbox files... 
from the File menu. Also, in the MailSteward Pro 
Settings, you can specify a folder that contains 
mbox files, that you want to be imported whenever 
you do an Archive. 

To export email from Outlook 2011 in a format that 
can be imported into MailSteward Pro, perform an Edit -> Select All in the folder or Inbox you 
wish to Export. Click & hold the mouse until you see the number count come up on the cursor. 
Then move the cursor over a Finder folder window and release the mouse. Wait while Outlook 
locks up & churns from exporting the emails. There will be no progress bar. This will fill the 
folder with .eml files of all the emails. The .eml files can then be imported into MailSteward Pro 
by selecting Import mbox files... from the File menu.
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Import MailSteward SQL File: 
MailSteward will export an SQL file of any list of archived or retrieved email. SQL files that 
have been created in this way can be read into a MailSteward Pro email archive database by 
selecting Import MailSteward SQL file... from the File menu.
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Check for Duplicate Email: 

As email is archived into the database, MailSteward Pro will automatically skip duplicates.  An 
email is considered a duplicate if there is an exact match on the From, To, Date and Time, and 
the first 500 characters of the body, with an email that is already in the database.  This will work 
most of the time, but sometimes a duplicate email will get through.  It is also possible that some 
duplicates may have gotten into the database because of changes in previous versions of 
MailSteward. Duplicate emails that are skipped during an archive are logged in the Duplicates 
Log. Click on Duplicates Log in the File menu to view the list of logged duplicates.

You can check for duplicates in the database by clicking on the Check for Duplicate Email item 
in the File menu. MailSteward Pro will then go through the entire database and look for email 
that has an exact match on the From, To, Date, minutes, seconds, and Subject. It does not match 
on the hour in case some email was archived in different time zones, and it does not match on the 
body, but it does look for a match on the subject.

The duplicate email will then be listed in the Browser window where it can be examined and 
deleted.
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Database Statistics Report: 

Clicking on the Database Statistics Report... item in the File menu will bring up the following 
Settings window. Clicking on Create Report will produce a report like the one below. 
 
From 2005-01-01 thru 2009-02-23

Total Number of emails in date range: 10,107

Number of emails with attachments:    1,325

Number of emails with tags:           2,511

Number of mailboxes:                  42

By Year:
2005:  5,020
2006:  5,087

Top 20 Senders:
1,164    RegNow Order Server <automated@regnow.com>
848      john seward <jns@pubblog.com>
797      MailSteward <mailstew@mailsteward.com>

         .
         .
         .
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Top 20 Recipients:
1,164    orders@mailsteward.com <orders@mailsteward.com>
942      jns@pubblog.com
654      nickseward@mac.com

         .
         .
         .

By Mailbox:
2,284    mailstew@mailsteward.com@mail.mailsteward.com/

INBOX
2,024    jns@pubblog.com@mail.pubblog.com/INBOX
1,875    Mac-nickseward/INBOX

         .
         .
         .
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System Requirements: 
The system requirements are simple.  You have to have a Macintosh running OS X 10.15 or 
greater (Catalina, Big Sur, Monterey, Ventura, Sonoma, Sequoia, Tahoe), and you have to be 
either using the macOS X Mail email client that came with your computer or no email client, in 
which case MailSteward Pro will automatically list all of your email accounts or mailboxes in 
the Settings. Or, if you are using Microsoft Entourage X, then you will need to drag your 
Entourage mailboxes onto your desktop or into a folder, and import the resulting mbox files into 
MailSteward Pro by selecting the Import mbox files... item from MailSteward Pro's File menu. 
Other email clients also have the ability to export mbox or .eml files.  MailSteward Pro supports 
POP, .Mac, and IMAP email accounts that are stored locally on your computer. The free version 
of MailSteward Pro has full functionality, but is limited to a capacity of 15,000 emails.

The other requirement for using MailSteward Pro, is that there must be a MySQL database server 
running for MailSteward Pro to connect to.

If you are running MacOS 10.15 (Catalina) or later, you will need to do this to give MailSteward 
Pro permission to access the disk:

Open the Privacy and Security system preferences panel.

Click on Full Disk Access.

Click the plus sign, add the MailSteward Pro application, and enable it.

Restart MailSteward Pro.
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